Les addons de Wamp ne sont plus disponibles

wampserver_logo

Certains développeurs ont déjà trouvé la solution pour faire cette manipulation, mais c'est toujours mieux de mettre à l'écrit pour que tout le monde puisse en profiter.

Depuis plusieurs mois, les adeptes de Wamp ont du mal à avoir les add-ons sur les versions PHP pour Wampserveur.

Un développeur, peut avoir besoin de basculer sur d'autres versions de PHP  (PHP 5.2, PHP 5.3, PHP 5.4 et plus) afin de couvrir beaucoup de projets. Pour ce faire, nous pouvons :

  • Prendre un PHP 5.4 compilé (par exemple) et décompresser l'archive dans le dossier C:\wamp\bin\php\php5.4.X (5.4.x étant la version de PHP, adaptez le chemin par votre installation).
  • Ouvrir le dossier d'une autre version de PHP déjà présente dans Wamp, par exemple php5.3.X. Recopiez les fichiers Wampserver.confphp.ini et phpForApache.ini dans le dossier php5.4.X.

Retournez dans le dossier php5.4.X, et éditez le fichier php.ini. Remplacez le chemin du dossier des extensions par celui du php5.4.X :

extension_dir = "c:/wamp/bin/php/php5.3.X/ext/"

Sans oublier de faire la même modification dans le fichier phpForApache.ini.

Redémarrez Wampserver et vous pourrez sélectionner votre nouvelle version dans le menu PHP > Version.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Captcha *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.