Montée de version JDK8 : un RESTeasy récalcitrant

java8

Dans le cadre d'une montée de version d'un projet Spring en JDK6 vers JDK8, nous avons dû faire le ménage dans nos librairies.

Pour la plupart des librairies, la migration se fait en douceur. Les choses se compliquent lorsque l'on arrive à Spring et sa myriade de modules. En effet La version 3.0.5.RELEASE de Spring que nous utilisions jusqu'à présent n'était pas compatible avec les nouvelles fonctionnalités JDK8. La compatibilité JDK8 ne commençant qu'à partir de la 4.0, nous sommes donc passés à la dernière version de l'époque : la 4.1.7.RELEASE.