XAMPP : régler le problème de lancement d’Apache sous Windows 10

XAMPP2

Windows 10 est le dernier né des OS de Microsoft. Comme à chaque fois, certains décident (comme moi) de se lancer et d’installer la dernière version sur sa machine. Et c’est là que les ennuis commencent !
Je ne rentrerai pas dans les détails en ce qui concerne les différents problèmes que l’on peut rencontrer sur cette dernière version sauf un qui me paraît assez gênant: l'erreur de lancement d’Apache sous XAMPP.

debut

Alors souvent la première chose qui nous vient à l’esprit, c’est fermer Skype et recommencer ! Sauf qu’ici nous n'avons pas un soucis de port 80 comme c’est le cas ci-dessous :

skype

La solution ?

Vous ouvrez votre invite de commande en mode administrateur (en faisant un clic droit -> Exécuter en tant qu’administrateur) et vous rentrez la commande suivante :

net stop W3SVC

 

En mode normal :

refuse

En mode Administrateur :

cmd stop

Cela va arrêter le service W3SVC nécessaire au fonctionnement du serveur IIS.

Vous pouvez ensuite relancer Apache sur XAMPP :

toutmarche

Miracle ! Ça fonctionne.

 

8 commentaires

  1. Merci beaucoup. Ça vient de me dépanner vraiment.

    J’utilisais WampServer, cette commande ne semble pas suffire. J’ai essayé aussi avec VertrigoServ qui ne veut pas démarrer. Il doit donc y avoir d’autres paramètres à prendre en compte.

    Par contre, tout fonctionne parfaitement avec Laragon qui a le mérite d’être très léger.

    Je précise à toutes fins utiles, le clic-droit se fait sur le bouton Windows de la barre de tâches, j’ai un peu cherché en fait 🙂 étant donné que c’est une fonctionnalité que j’utilise très peu (et que peu de gens utilisent finalement).

  2. Bonjour,

    Merci pour le message.
    Effectivement, j’ai oublié de rajouter ce détail qui a tout de même son importance!

  3. Bonjour,
    Merci du tuyau, mais il faut chaque fois refaire la manipulation. J’ai donc désactivé « Service de publication World Wide Web » dans « services.msc »

  4. ya un probleme du port
    peut etre t entrain d’utiliser skype ou autre
    (skype et xampp ont le meme port )
    essaye de se deconnecter de skype et refais l’etape
    bon courage

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Captcha *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.